Project

General

Profile

Bug #5005

regular user couldn't start kepler after it was installed on windows 7

Added by Jing Tao over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
installer
Target version:
Start date:
05/12/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5005

Description

Jianwu, can you start the kepler on windows 7. I can installed it successfully.
But it can't be started.

Last time, RC1 could be installed and started.

Jing, I have to right click the icon and use 'Run as administrator', or start
cmd using 'Run as administrator' and execute the Kepler.bat. Otherwise, it will
have access denied exception:

Exception in thread "main" java.io.FileNotFoundException: C:\Program
Files\Keple
r-2.0-RC2\build-area\present.txt (Access is denied)
...


Related issues

Blocked by Kepler - Bug #4943: RC5 Installer Tracking BugResolved04/19/2010

History

#1 Updated by Jing Tao over 9 years ago

Here is the error message i got:

C:\Program Files\Kepler-2.0-RC2>kepler.bat
Exception in thread "main" java.io.FileNotFoundException: C:\Program Files\Kepl
r-2.0-RC2\build-area\present.txt (Access is denied)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:105)
at org.kepler.build.modules.Module.readPresent(Module.java:209)
at org.kepler.build.modules.Module.transformName(Module.java:296)
at org.kepler.build.modules.Module.<init>(Module.java:141)
at org.kepler.build.modules.Module.<init>(Module.java:186)
at org.kepler.build.modules.ModulesTxt.readHelper(ModulesTxt.java:148)
at org.kepler.build.modules.ModulesTxt.read(ModulesTxt.java:120)
at org.kepler.build.modules.ModulesTxt.init(ModulesTxt.java:57)
at org.kepler.build.modules.ModuleTree.init(ModuleTree.java:96)
at org.kepler.build.modules.ModulesTask.init(ModulesTask.java:86)
at org.kepler.build.runner.Kepler.main(Kepler.java:76)
Caused by: java.io.FileNotFoundException: C:\Program Files\Kepler-2.0-RC2\build
area\present.txt (Access is denied)
at java.io.FileOutputStream.open(Native Method)
at java.io.FileOutputStream.<init>(Unknown Source)
at java.io.FileOutputStream.<init>(Unknown Source)
at java.io.FileWriter.<init>(Unknown Source)
at org.kepler.build.UpdatePresentTxt.run(UpdatePresentTxt.java:66)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:101)
... 10 more
--- Nested Exception ---

#2 Updated by Jing Tao over 9 years ago

I changed the permission of the files present.txt and published.txt for regular user: adding write permission. Then it works.

I read code a little bit: The run method of UpdateModule class need to be called for the two files. I guess this is the reason the regular user need write permssion. This is new feature on rc2 since I couldn't find the two files on rc1.

#3 Updated by Jing Tao over 9 years ago

<jing> now i will install rc1 as admin, then run it as regular user.
<jing> to see what will happen.
<davidwelker> ok
<davidwelker> but I don't think it is necessary
<jing> really?
<davidwelker> yeah
<davidwelker> this was based on the theory that the installer was doing something differently
<davidwelker> but it turns out a different part of the system is
<davidwelker> namely, the PatchChecker
<davidwelker> which wasn't working in rc1
<davidwelker> it works in rc2, but writes files in the wrong place
<davidwelker> you know
<davidwelker> I think we will have another problem
<davidwelker> I think the module manager is going to fail
<jing> :(
<davidwelker> because it is going to write modules.txt in the build-area
<davidwelker> we are going to need it to behave differently for these admin installs
<jing> okay. i will test this on rc 3
<davidwelker> yes
<jing> cool
<davidwelker> excellent

#4 Updated by David Welker over 9 years ago

Since published.txt and present.txt are now stored and written to the cache, this bug now should be fixed. Closing.

#5 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5005

Also available in: Atom PDF