Project

General

Profile

Bug #5091

Dragging and dropping report layout items NPEs

Added by Derik Barseghian about 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Category:
reporting
Target version:
Start date:
07/09/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5091

Description

Often when you're dragging and dropping a report item in the report designer, you get NPEs spewing on the console. This is a been an issue for a long time and it doesn't cause problems, but it can be annoying.

java.lang.NullPointerException
at javax.swing.plaf.basic.BasicTextUI$TextTransferHandler.getImportFlavor(BasicTextUI.java:2183)
at javax.swing.plaf.basic.BasicTextUI$TextTransferHandler.canImport(BasicTextUI.java:2409)
at javax.swing.TransferHandler$DropHandler.dragEnter(TransferHandler.java:651)
at java.awt.dnd.DropTarget.dragEnter(DropTarget.java:337)
at javax.swing.TransferHandler$SwingDropTarget.dragEnter(TransferHandler.java:573)
at sun.awt.dnd.SunDropTargetContextPeer.processEnterMessage(SunDropTargetContextPeer.java:307)
at sun.awt.dnd.SunDropTargetContextPeer.access$500(SunDropTargetContextPeer.java:54)
at sun.awt.dnd.SunDropTargetContextPeer$EventDispatcher.dispatchEnterEvent(SunDropTargetContextPeer.java:771)
at sun.awt.dnd.SunDropTargetContextPeer$EventDispatcher.dispatchEvent(SunDropTargetContextPeer.java:739)
at sun.awt.dnd.SunDropTargetEvent.dispatch(SunDropTargetEvent.java:29)
at java.awt.Component.dispatchEventImpl(Component.java:3926)
at java.awt.Container.dispatchEventImpl(Container.java:2068)
at java.awt.Component.dispatchEvent(Component.java:3903)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4256)
at java.awt.LightweightDispatcher.trackMouseEnterExit(Container.java:4061)
at java.awt.LightweightDispatcher.processDropTargetEvent(Container.java:3999)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3861)
at java.awt.Container.dispatchEventImpl(Container.java:2054)
at java.awt.Window.dispatchEventImpl(Window.java:1801)
at java.awt.Component.dispatchEvent(Component.java:3903)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

History

#1 Updated by Derik Barseghian over 8 years ago

This seems to be caused by dragging a report layout item over a text-area.

#2 Updated by Derik Barseghian over 8 years ago

This no longer happens.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5091

Also available in: Atom PDF