Project

General

Profile

Bug #5359

SpanToDT NoClassDefFoundError

Added by Derik Barseghian over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Category:
sensor-view
Target version:
Start date:
03/29/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5359

Description

My guess is this is related to a limitation on number of control connections to SPAN.
I'll try to narrow it down, but for now:

) Started running SpanToDT on gumstix. tail -f log, looks fine.
) Import sensor site with Kepler, try to execute.
*) SpanTODT gives this error, and seems to stop writing data (though flush messages keep coming out)

Exception in thread "Thread-1" java.lang.NoClassDefFoundError: ptolemy/util/MessageHandler
at util.SpanToDT$WriteToDataTurbineThread.run(SpanToDT.java:384)
Caused by: java.lang.ClassNotFoundException: ptolemy.util.MessageHandler not found in java.lang.ClassLoader$1{urls=[file:/home/ubuntu/spanTodt/../dataturbine/bin/rbnb-3.2b5.jar,file:/home/ubuntu/spanTodt/sensorview-utils-1.0.jar], parent=null}
at java.net.URLClassLoader.findClass(URLClassLoader.java:529)
at java.lang.ClassLoader.loadClass(ClassLoader.java:341)
at java.lang.ClassLoader$1.loadClass(ClassLoader.java:1112)
at java.lang.ClassLoader.loadClass(ClassLoader.java:293)
at util.SpanToDT$WriteToDataTurbineThread.run(SpanToDT.java:384)

History

#1 Updated by Daniel Crawl over 8 years ago

sensorview-utils.jar was missing some classes.

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5359

Also available in: Atom PDF