Project

General

Profile

Bug #5530

Sanparks skin shows update and delete action when user public reads a FGDC package

Added by Jing Tao almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
metacat
Target version:
Start date:
10/31/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5530

Description

Here is an email from Judith:

Hi Jing
I have successfully uploaded a number of GIS layers What concerns me is
that if I don't login as myself but just as a public person when I open
one of the GIS files Say Kruger National Park boundary the options that
I get below still has the update and delete buttons. Surely they should
only be allowed to download the files
Tx a mil
J

I tried those actions (update and delete), fortunately they didn't work for user public. But it is still confusing. We needs to hide them for user public.


Related issues

Is duplicate of Metacat - Bug #5394: FGDC interface does not correctly show controls and permission settingsResolved05/05/2011

History

#3 Updated by Jing Tao over 8 years ago

If fgdc-root.xsl, it has the control to display the buttons or not. The control is the parameter "enableFGDCediting". However, this param was not be set in Metacat. In MetacatHandler class, we add code to set parameter "enableFGDCediting", then it works.

Ben:

I have a question about the "Set Access" button. Currently, if a doc is NOT public readable, the "public read" check box for the button will be unchecked; if a doc is public readable, the "public read" check box for the button will be checked. I think we should do the opposite way.What do you think?

#4 Updated by ben leinfelder over 8 years ago

I think the checkbox should reflect the current state of the document. If it is unchecked, that indicates that it is not publicly readable. If I check it and update the document, then it should stay checked to indicate that my change was successful. If I wish to revoke public read access, I should be able to uncheck the box and update the document at which point it will remain unchecked to indicate that the document is not publicly readable.

#5 Updated by Jing Tao over 8 years ago

Ben:

Okay. This is the current behavior. I am going to close the bug.

#6 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 5530

Also available in: Atom PDF