Project

General

Profile

Bug #5732

EML 2.1.1 option should be added to metacat data sources in kepler

Added by Derik Barseghian over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
data access
Target version:
Start date:
11/08/2012
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5732

Description

EML 2.1.1 option should be added to metacat data sources in kepler

History

#1 Updated by Derik Barseghian over 6 years ago

Enabled querying for eml 2.1.1 packages at r31055.

To close this bug, test querying for and using an eml 2.1.1. dataset in Kepler.

I was able to search for, find and instantiate one from our EVOS metacat (entry not included in kepler ecogrid configuration file), but got an IllegalActionException from the EML 2 Dataset actor when trying to run a very simple workflow including it. This is possibly unrelated to eml 2.1.1; I ran into a number of problems when trying to use the same dataset from local disk -- i.e. via instantiating a blank EML 2 Dataset actor and configuring it to use local copies of the eml and data.

#2 Updated by Jing Tao over 6 years ago

Derik added eml 2.1.1 to the configuratin.xml in both ecogrid and reporting modules. However, we still can't see them. It turns out that we need to modify the registry at http://knb.ecoinformatics.org/registry/services/RegistryService, which points to the library.kepler-project.org/kepler.

To update the registry in the metacat, we should do the following commands under seek/projects/ecogrid:
ant test -Dargs="update D5BF5D9486A5D6032A457FF5DFABAC9A ecogridService.12019158467.4 knbauthenqueryservice.xml http://knb.ecoinformatics.org/registry/services/RegistryService"

The args can be:
[java] Usage: java RegistryServiceClient add session_id local_file GSH
[java] Usage: java RegistryServiceClient update session_id docid local_file GSH
[java] Usage: java RegistryServiceClient remove session_id docid GSH
[java] Usage: java RegistryServiceClient list session_id GSH
[java] Usage: java RegistryServiceClient query session_id query_field query_string GSH

Note: you have to delete .kepler in order to see the new changes.

We also searched the knb metacat for eml 2.1.1 documents in the kepler. Then we dragged the result items to the kepler canvas and made a simple workflow. It worked. So the new feature has been added.

#3 Updated by Derik Barseghian over 6 years ago

.kepler has to be deleted because the service list gets serialized to a java object in the cache dir.

#4 Updated by Redmine Admin almost 6 years ago

Original Bugzilla ID was 5732

Also available in: Atom PDF