Project

General

Profile

Bug #5846

Morpho says that it saved an eml 2.0.1 document, but it is eml 2.1.1

Added by Jing Tao almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - dsp
Target version:
Start date:
02/04/2013
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5846

Description

I found if use want to save an old version locally, actually the saving upgraded the eml version.

1. Open a online 2.0.1 eml document.
2. Don't upgrade the eml document during the openning.
3. Save the document locally while uncheck the updating box.

Open the document and you will find it is eml 2.1.1 after the saving.

History

#1 Updated by ben leinfelder almost 8 years ago

Since Morpho only ever "knows" how to save the current version of EML, we should not allow users to save the package unless it has been updated. Perhaps the dialogs need to be updated to reflect this policy, but it sounds like it works as we'd expect it to.

#2 Updated by Jing Tao almost 8 years ago

Hrrm, I couldn't reproduce the bug any more. I opened an eml 2.0.1 on the network location without any modification, then saved it locally. The local copy is still eml 2.0.1. I tried the couple times, every time is the same.

Since the scenario just like copying a network one to the local, it is not necessary to upgrade the eml version. However, ben, if you want to force the update, you may create another bug. I am just closing this one.

#3 Updated by ben leinfelder almost 8 years ago

Oh, I misunderstood when I first read this.

Yes, you should be able to copy an old EML 2.0.1 file from the network to the local store without upgrading it to EML 2.1.1. But doing pretty much anything else with this file after that requires upgrading it to the latest version.

No new bug needed and thanks for closing this.

#4 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 5846

Also available in: Atom PDF