Project

General

Profile

Bug #5848

Ensure Morpho can edit EML contributed by DataUp

Added by ben leinfelder over 6 years ago. Updated over 6 years ago.

Status:
New
Priority:
Normal
Category:
morpho - general
Target version:
Start date:
02/05/2013
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5848

Description

Tried to open network EML 2.1.1 contributed by DataUp tool:
https://oneshare.unm.edu/knb/d1/mn/object/ark:/90135/q13j39xf/4/mrt-eml.xml
Got a few errors while it tried to parse the package (butterfly still flapping):
physicalList is null!
physicalList is null!
physicalList is null!
physicalList is null!
Invalid Id

History

#1 Updated by ben leinfelder over 6 years ago

After overcoming the error message about the missing physical entity information I was able to open the package in Morpho. The data was not loaded, but the attribute metadata and columns were displayed.

But there are differences with what metadata fields Morpho can safely edit. In cases where the wizard pages cannot handle all the EML fields, the horrible Tree Editor window is displayed. This is useable, but not ideal.

Here are the xpaths that Morpho cannot currently handle in the wizard pages:

/abstract

/project/abstract1/para1
/project/funding1

/intellectualRights

Either we can try to support them in Morpho, or we can get DataUp to change where it places the information in EML. For /abstract we assume /abstract/para. Will have to look into the other three.

#2 Updated by ben leinfelder over 6 years ago

Basic open operation works, but as noted in the comments, editing these packages will be tricky since Morpho expects the data pointers to be in a particular sopt in EML whereas DataUp relies on ORE objects only and does not include data pointers from entity/physical to the actual data that is being described.

Moving this to later release of Morpho (2.1)

#3 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 5848

Also available in: Atom PDF