Project

General

Profile

Actions

Bug #5861

closed

Local delete doesn't delete the file storing the system metadata

Added by Jing Tao almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - dsp
Target version:
Start date:
02/12/2013
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5861

Description

The delete of local data package does delete the package itself. But it doesn't delete the stored system metadata file.

Actions #1

Updated by ben leinfelder almost 10 years ago

I think it's safe to remove the SystemMetadata file as well. We should not, however, delete any referenced data files since they might be included in other packages (I know making a duplicate of an EML package will preserve the reference to the same data).

Actions #2

Updated by Jing Tao almost 10 years ago

yeah. we should keep the data file. Actually, the delete doesn't remove the data file.

However, I think we should remove the ore document and its system metadata because the metadata (eml) in the ore doesn't exist any more.

By the way, i believe the only way we can figure out the id of an ore document is "resourceMap_"+metadata id.

Actions #3

Updated by Jing Tao almost 10 years ago

Now morpho will delete both the metadata (including the associated system metadata) and the ore document(including the associated system metadata) if it exists.

Actions #4

Updated by Redmine Admin almost 10 years ago

Original Bugzilla ID was 5861

Actions

Also available in: Atom PDF