Project

General

Profile

Bug #5869

Test morpho 2.0 on windows

Added by Jing Tao over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Category:
morpho - general
Target version:
Start date:
02/18/2013
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5869

Description

Both Ben and I are working morpho on Mac OS X. We need to test it on windows.
The tests inlcude:
1. Upgrade the morpho from 1.x to 2.0.
2. Save a data package to the local and network.
3. Update the data package to the local and network.
4. Search the lcoal and network.
5. Test against a GMN.

History

#1 Updated by ben leinfelder over 7 years ago

For the CCIT meeting I built RC1 installers and made them available here:
http://bespin.nceas.ucsb.edu/dataone/downloads/

I can also make RC2 installers soon for additional testing.

#2 Updated by Jing Tao over 7 years ago

I tested the morpho from the trunk on a Windows 7 VM in my linux box. The issue i saw is that i can't log in. But i can log in in my mac. There is no error message. I did see something like:

[java] <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
[java] <html><head>
[java] <title>302 Found</title>
[java] </head><body>
[java] <h1>Found</h1>
[java] <p>The document has moved <a href="https://test.cilogon.org/">here</a>.</p>
[java] <hr>
[java] <address>Apache/2.2.3 (CentOS) Server at test.cilogon.org Port 443</address>
[java] </body></html>

However, i saw this message in my successful login on my mac as well.

I am not sure if this is a windows issue or just my computer issue. Ben, would you please test this as well?

Here are what i tested:

1. Upgraded morpho from 1.8 to 2.0
2. Created and updated a data package with a data file.
3. Open and search
4. Created a new profile.

Those parts worked well.

#3 Updated by ben leinfelder over 7 years ago

Creating a new profile using RC-1 in Win 7, I got this warning message:
"C:\Users\Visitor\.morpho\profiles\brl\data\.data.properties (The requested operation cannot be performed on a file with a user-mapped section open)"
But the profile seems to have been created.

#4 Updated by ben leinfelder over 7 years ago

But then when I relaunch Morpho it fails with these messages (I see some progress bars briefly so perhaps this version is still trying to upgrade an already upgrade profile?):
"Error parsing Query (org.xml.sax.SAXParseException)."
"Content is not allowed in prolog."

#5 Updated by Jing Tao over 7 years ago

benMac, would you please run Morpho from the trunk? Today i just fixed a bug about the upgrading the upgraded profile.

http://bugzilla.ecoinformatics.org/show_bug.cgi?id=5870

There is no problem for me to generate a profile. I am thinking if this is caused by some restriction on the visitor account.

#6 Updated by ben leinfelder over 7 years ago

I converted the CSR generation in the ECP client code to use Bouncy Castle rather than the classes that were removed in Java 7. So login should now work on Windows (it was really an issue for all systems that are using Java 7). You may need to remove the ECP client from your maven (.m2) directory so that you get the latest version that dev-testing.dataone.org has built.

#7 Updated by Jing Tao over 7 years ago

After updated the ECP lib, now I can log in. However, when i saved a data package to the network, I got this error:

[java] Problem Saving package:
[java] class java.io.IOException: The system cannot find the path specified
[java] org.dataone.service.exceptions.ServiceFailure: class java.io.IOExcep
tion: The system cannot find the path specified
[java] at java.io.WinNTFileSystem.createFileExclusively(Native Method)
[java] at java.io.File.createTempFile(File.java:1879)
[java] at org.dataone.mimemultipart.SimpleMultipartEntity.generateTempF
ile(SimpleMultipartEntity.java:214)
[java] at org.dataone.mimemultipart.SimpleMultipartEntity.addFilePart(S
impleMultipartEntity.java:88)
[java] at org.dataone.client.MNode.create(MNode.java:490)
[java] at org.dataone.client.MNode.create(MNode.java:473)
[java] at edu.ucsb.nceas.morpho.datastore.DataONEDataStoreService.save(
DataONEDataStoreService.java:648)
[java] at edu.ucsb.nceas.morpho.datastore.DataONEDataStoreService.save(
DataONEDataStoreService.java:505)
[java] at edu.ucsb.nceas.morpho.datastore.DataStoreServiceController.sa
ve(DataStoreServiceController.java:787)
[java] at edu.ucsb.nceas.morpho.datastore.DataStoreServiceController.sa
ve(DataStoreServiceController.java:726)
[java] at edu.ucsb.nceas.morpho.datapackage.SaveDialog.save(SaveDialog.
java:422)
[java] at edu.ucsb.nceas.morpho.datapackage.SaveDialog.executeButton_ac
tionPerformed(SaveDialog.java:363)
[java] at edu.ucsb.nceas.morpho.datapackage.SaveDialog$SymAction.action
Performed(SaveDialog.java:262)
[java] at javax.swing.AbstractButton.fireActionPerformed(AbstractButton
.java:2018)
[java] at javax.swing.AbstractButton$Handler.actionPerformed(AbstractBu
tton.java:2341)
[java] at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultBut
tonModel.java:402)

#8 Updated by Jing Tao over 7 years ago

The issue is in the d1_common_java module.

The method generateTempFile() in the SimpleMultipartEntity creates a temp file in the tmpDir: File tmpDir = new File(Constants.TEMP_DIR);

However, the Constants.TEMP_DIR = "/tmp".

It is not windows friendly. We need to change it.

#9 Updated by ben leinfelder over 7 years ago

There's no reason to specify a temp directory - we can let the OS decide where to put them. Will talk with Rob about this.

#10 Updated by Jing Tao over 7 years ago

i am sending an email to him.

#11 Updated by ben leinfelder over 7 years ago

Updated d1_common_java (will be in 1.2-SNAPSHOT) to let the OS decide which temp directory to use. Let's give that a try.

#12 Updated by Jing Tao over 7 years ago

After updated the d1_common, i tested morpho against Metacat MN and GMN. It worked well to me.

#13 Updated by Jing Tao over 7 years ago

I think we can close the bug.

#14 Updated by Redmine Admin about 7 years ago

Original Bugzilla ID was 5869

Also available in: Atom PDF