Project

General

Profile

Task #5926

Feature #5810: Implement SOLR-based search

Task #5921: Design and implement Metacat-Index module

Metacat-index doesn't build solr index during a Metadata inserting document

Added by Jing Tao over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
04/25/2013
Due date:
% Done:

0%

Estimated time:

Description

I inserted an eml document through the metacat devtools.html, but the metacat-index didn't build the solr index.

History

#1 Updated by Jing Tao over 6 years ago

  • Status changed from New to Resolved

It turned out that the solr doc was generated. However, the building index and querying index use different EmbeddedSolrServer object, the new index only shows up after tomcat restarted.

If we add the code to reload solr core container, the problem is resolved. But I am not sure the reloading is very expensive or not. So far, it seems fine.

Also available in: Atom PDF