Project

General

Profile

Bug #6022

Morpho error on government computer with Windows 7

Added by Sarah Clark over 6 years ago. Updated over 6 years ago.

Status:
In Progress
Priority:
Normal
Category:
-
Target version:
-
Start date:
07/03/2013
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

"Hi Sarah,
I am trying to install Morpho on my government computer with Windows 7 and am having some difficulty. I downloaded the file, started the installer, it said it was installed correctly and all seems well, but when I open it, it gives me a "Failed to create config directory' and closes."

History

#1 Updated by ben leinfelder over 6 years ago

Can this person run Morpho as an administrator account? It should only be trying to write to their "home" directory and the installation directory.

#2 Updated by Sarah Clark over 6 years ago

Tammy tried it under the admin account and got the same error message

#3 Updated by ben leinfelder over 6 years ago

I'll try it on a Windows 7 virtual machine and see what I can figure out for troubleshooting. It does, generally, work on Windows 7...so there's definitely light at the end of the tunnel for them.

#4 Updated by ben leinfelder over 6 years ago

  • Status changed from New to In Progress

Using a Windows 7 virtual box instance:
-I created a non-admin account ("leinfelder")
-installed Morpho 1.10.0, opting to run the installer as an admin account ("visitor") and put it in the Program Files directory
-ran Morpho as non-admin account ("leinfelder").
-created profile as expected (C:\Users\leinfelder\.morpho)

#5 Updated by Sarah Clark over 6 years ago

"Hi Tammy - on Windows 7 Ben was able to install Morpho logged in to the computer as the administrator and then logged out and logged in as the regular user, and was able to launch Morpho. The Morpho files are written to something like: 'C:\Users\neher\.morpho'. When you tried as the administrator did you still receive the configuration error the same way? Also have you by chance ever had an older version of Morpho on this computer?
Thanks,
Sarah"

"Hi,
This is a brand new labtop, so the only version might be the one I had saved and tried to install from the day before. I will run the uninstall and then reinstall it and see if that helps. I have sent this lap top over to our lab, so it might be a couple of days until I get it back to mess with it. It sounds like the NPS had no problem with their Windows 7 machines so it might just be something screwy with mine.
-t"

Also available in: Atom PDF