Project

General

Profile

Bug #6193

obsoleted versions of objects show up in KNB theme

Added by Matt Jones over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
10/31/2013
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

From the MetacatUI page for solson.11.6, I logged in and used the Publish button to generate the DOI doi:10.5063/F1QN64NZ. Now, when searching the KNB skin for the phrase 'olson', both the new document (doi:10.5063/F1QN64NZ) and the now obsoleted version of the document (solson.11.6) show up in search results. Correct behavior would be to only show non-obsoleted versions in search results by default in MetacatUI.

N.B. Of course, the SOLR search itself should be able to search and find obsoleted versions.


Related issues

Is duplicate of Metacat - Bug #6057: Publish DOI action does not update revision history correctlyClosed

History

#1 Updated by ben leinfelder over 6 years ago

  • Target version changed from 1.3.0 to 2.3.0
  • Project changed from MetacatUI to Metacat

This is not a UI issue, the SM.obsoletedBy field is null for 'solson.11.6'. This was supposed to be fixed by https://projects.ecoinformatics.org/ecoinfo/issues/6057

#2 Updated by Matt Jones over 6 years ago

That's not what I am seeing. Did you change something manually?

The sysmeta for the new DOI: https://knb.ecoinformatics.org/knb/d1/mn/v1/meta/doi:10.5063/F1QN64NZ
says:
<obsoletes>solson.11.6</obsoletes>

The sysmeta for solson.11.6: https://knb.ecoinformatics.org/knb/d1/mn/v1/meta/solson.11.6
says:
<obsoletes>solson.11.5</obsoletes>

Neither of them sets obsoletedBy. The newest document in the revision chain (doi:10.5063/F1QN64NZ) was generated by clicking the Publish button on the KNB, so any issues with setting obsoletes chaining are probably triggered in that process. Who is responsible for setting obsoletedBy? It seems like Metacat should be setting it during the update() operation.

#3 Updated by ben leinfelder over 6 years ago

Corrected my comments (was reading too fast this morning) - yes, the MN.update() call should be updating the obsoletedBy value:

// add the newPid to the obsoletedBy list for the existing sysmeta
existingSysMeta.setObsoletedBy(newPid);

#4 Updated by ben leinfelder over 6 years ago

  • Status changed from New to In Progress

#5 Updated by ben leinfelder over 6 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF