Project

General

Profile

Feature #6196

ORE documents should be generated for new EML records from the Metacat API

Added by Matt Jones about 6 years ago. Updated about 6 years ago.

Status:
Rejected
Priority:
Normal
Category:
metacat
Target version:
Start date:
11/01/2013
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

Currently, if a metadata document is uploaded via the Metacat API (action=insert or action=update), it does not contain an ORE document, as that API doesn't support it's upload. Consequently, even if we manually generate ORE maps from the admin control panel, each update of an object fails to create an associated ORE map even if it existed for the prior version. Thus, the data set drops out of any searches including the 'Has data' flag.

To fix this, just as we generate SystemMetadata automatically, we should also automatically generate an ORE document for the new metadata document that links all of the referenced data files into the resource map. This will avoid the need for large batch generation of ORE documents.


Related issues

Is duplicate of Metacat - Bug #6061: Ensure that all packages from metacat API have resource mapClosed09/02/2013

History

#1 Updated by ben leinfelder about 6 years ago

  • Target version changed from 2.4.0 to Unspecified
  • Status changed from New to Rejected

Also available in: Atom PDF