Project

General

Profile

Actions

Bug #6339

closed

Firefox 16.0.2 is getting JS errors and not loading properly

Added by Lauren Walker almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
12/30/2013
Due date:
% Done:

40%

Estimated time:
Bugzilla-Id:

Description

Version 16.0.2 of Firefox is not displaying almost anything correctly - there are a couple errors of "Syntax error: invalid quantifier" pointing to jQuery.js

Actions #1

Updated by Lauren Walker almost 9 years ago

  • % Done changed from 0 to 40

I've found that the embedded Javascript in the search.html template for DataCatalogView is causing this error. I suspect there is a JS character messing with the regular expression in the .html() function of jQuery (line 6067).

Actions #2

Updated by Lauren Walker almost 9 years ago

  • Status changed from New to Resolved

Finally figured out that the minimum year and maximum year inputs were including the quotation marks inside the JS for the value attribute, which was causing an error, so I just simplified it to <%=x%> instead of printing the quotation marks via print()

And the 'invalid quantifer' error was caused by the pattern attribute on these inputs, which was interfering with the regular expression function acting on it via the .html() jQuery function. So I removed that attribute altogether since it isn't necessary.

Some other small stye changes were made to make it look better in Firefox 16.

Actions

Also available in: Atom PDF