Project

General

Profile

Task #6358

Story #6330: Address feedback on MetacatUI features and usability

Address feedback from Corinna Gries

Added by Lauren Walker almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
01/06/2014
Due date:
% Done:

0%

Estimated time:
0.00 h

Description

I went through the new KNB search interface and I really like it. It's pretty fast even for the 'anything' search. I also like how the faceted search is implemented where I can see what the words I can search on, and how many datasets I can expect.

just a few things to nag about (I am attaching some screenshot to illustrate my complaints.)
It took me a while to get the hang of the map interface. (screenshots 1-4) I am getting different numbers of datasets in the red dots in the same general geographic area at every zoom level. E.g. starting with 12 around San Francisco on the world level and then zooming in on San Miguel Island and obviously a PISCO site in Cuyler harbor the number seems to increase at the every zoom level. But the most confusing thing happens when the cursor hovers over a dataset link in right hand window. The map in the background flips to an extremely high zoom level and it is clearly on land (screenshot 4), not in the ocean. I don't have any control over the map at that time because it flips back as soon as I move the cursor off the dataset link and back over the map. This appears to be an almost random zoom, at least it is not obvious to me what I am seeing on the map when hovering over a dataset link.

One minor thing that bothered me was the fact that the text on some pages didn't seem to wrap properly in my browser (Firefox 26.0). In particular this FAQ page https://knb.ecoinformatics.org/m/#external//emlparser/docs/eml-2.1.1/eml-faq.html always had a few letters off the right edge and I needed to use the horizontal scroll bar to get to them, no matter how big I made the window.

And last (5. screenshot), I did a search on nitrogen in the attribute search box, then clicked on 'data' in the main menu expecting to start over again and the 'nitrogen' filter disappeared from the search display, but the datasets were still filtered (i.e. still 102 data packages). The only indication that I still had a filter set was the 'clear all filters' button. Maybe that's too picky and more a matter of getting used to, so no real complaint here unless many people react like that.

History

#1 Updated by Lauren Walker almost 8 years ago

just a few things to nag about (I am attaching some screenshot to illustrate my complaints.)
It took me a while to get the hang of the map interface. (screenshots 1-4) I am getting different numbers of datasets in the red dots in the same general geographic area at every zoom level. E.g. starting with 12 around San Francisco on the world level and then zooming in on San Miguel Island and obviously a PISCO site in Cuyler harbor the number seems to increase at the every zoom level.

This is happening because the results are paged - so as she zooms in the cluster counts may change as the results on the current page change

But the most confusing thing happens when the cursor hovers over a dataset link in right hand window. The map in the background flips to an extremely high zoom level and it is clearly on land (screenshot 4), not in the ocean. I don't have any control over the map at that time because it flips back as soon as I move the cursor off the dataset link and back over the map. This appears to be an almost random zoom, at least it is not obvious to me what I am seeing on the map when hovering over a dataset link.

This is a bug I have noticed too and it is caused by adjustment of the longitude when panning so that the result list doesn't get in the way. I will change it so that it just pans to the marker without an adjustment, even though at some browser widths it will be covered by a few pixels.

#2 Updated by Lauren Walker almost 8 years ago

  • translation missing: en.field_remaining_hours set to 0.0
  • Status changed from New to Resolved

#3 Updated by Lauren Walker almost 8 years ago

  • Estimated time set to 0.00 h

Forgot the last two points:

One minor thing that bothered me was the fact that the text on some pages didn't seem to wrap properly in my browser (Firefox 26.0). In particular this FAQ page https://knb.ecoinformatics.org/m/#external//emlparser/docs/eml-2.1.1/eml-faq.html always had a few letters off the right edge and I needed to use the horizontal scroll bar to get to them, no matter how big I made the window.

I will need to fix the CSS for this - Ticket 6363

And last (5. screenshot), I did a search on nitrogen in the attribute search box, then clicked on 'data' in the main menu expecting to start over again and the 'nitrogen' filter disappeared from the search display, but the datasets were still filtered (i.e. still 102 data packages). The only indication that I still had a filter set was the 'clear all filters' button. Maybe that's too picky and more a matter of getting used to, so no real complaint here unless many people react like that.

It is definitely an issue - created ticket 6364

Also available in: Atom PDF