Project

General

Profile

Task #6359

Story #6330: Address feedback on MetacatUI features and usability

Address feedback from Mark Servilla

Added by Lauren Walker almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
01/06/2014
Due date:
% Done:

0%

Estimated time:

Description

Very nice update, indeed. Kudos to the development team. My initial testing/evaluation was blazing fast, but eventually the entire site became nearly non-responsive at approximately Sun Jan 5 20:13:00 MST 2014. My primary test search term was "lter" or "LTER" - this was repeated many times (~50); fully closing Chrome and restarting evaluation did not help, so I assumed it was the site refresh that was choking.

Please find my brief evaluation report below (apologies for its brevity), along with some screen captures (attachments). Also note that my focus was on negative aspects of my experience (there are many positive aspects not recorded).

OS: Apple OS X 10.8.5
Browser: Chrome 31.0.1650.63

General Impressions
- Filter dialog better to be fully expanded, otherwise it may go unnoticed;
without the filter dialog expanded, the user does not see search term/
phrase.
- "Share your data" link on search result page seems out of place; best
from home page and main title bar.
- Display of search results on top of map makes map seem cluttered.
- Main title bar obscures some map markers and popup information.
Searching with term "lter" 
- Map does not always render during search (see attachment lter-1); this
seemed to become consistent after extensive searches for "lter".
- Map will change view when hovering over search result (search for "lter"
and then select map marker for #3 results in Idaho - see attachments
idaho-1 and idaho-2); this artifact seems to happen when zooming into
a map marker that has more than one data package available.
- Selecting map marker for #3 results in Idaho display results indicating
1 to 3 of 3 data packages, but the list displays greater than 3 (I
believe all 214; see attachment idaho-3).
- Many data packages in search results for "lter" do not appear to be
related to LTER or have the term (even sub-term) "lter" in the displayed
metadata - see 13 data package off coast of Washington in the Puget
Sound.
- Map page becomes non-responsive; perhaps too many clicks on controls
leads to a extensive latency.top
- Current knb.ecoinformatics.org site returns 8064 data packages for full
"lter" search or 7209 from title/abstract/...; new site returns only 214.
Metadata Presentation
- Empty boxes better to state "no-content" or "content not available"; the
empty box by it self leaves one to wonder if content does exist, but
did not display for technical reasons.
- Download button at top of page only downloads EML metadata (and system metadata) without the
data entity(s); I made the assumption that the complete data package
would be zipped and downloaded; inflated zip file has directory called
"data", which I would have assumed to hold the data entity.

History

#1 Updated by Lauren Walker almost 8 years ago

General Impressions
- Filter dialog better to be fully expanded, otherwise it may go unnoticed;
without the filter dialog expanded, the user does not see search term/
phrase.
I originally had the Filters sidebar collapsed so that the map wouldn't be so cluttered, but since a couple people have suggested this I will have it expanded upon page load

- "Share your data" link on search result page seems out of place; best
from home page and main title bar.

This has been suggested by a couple people now and I agree so I'll remove it. Ticket 6360

- Display of search results on top of map makes map seem cluttered.
- Main title bar obscures some map markers and popup information.
Searching with term "lter"
- Map does not always render during search (see attachment lter-1); this
seemed to become consistent after extensive searches for "lter".
I'll ask for error details on this since I can't seem to reproduce it

- Map will change view when hovering over search result (search for "lter" 
and then select map marker for #3 results in Idaho - see attachments
idaho-1 and idaho-2); this artifact seems to happen when zooming into
a map marker that has more than one data package available.

This is the same issue Corrina was experiencing and has been resolved

- Selecting map marker for #3 results in Idaho display results indicating
1 to 3 of 3 data packages, but the list displays greater than 3 (I
believe all 214; see attachment idaho-3).

It looks like the list wasn't cleared before a new search - I will try to recreate to find the issue

- Many data packages in search results for "lter" do not appear to be
related to LTER or have the term (even sub-term) "lter" in the displayed
metadata - see 13 data package off coast of Washington in the Puget
Sound.

The search is picking up 'lter' from the word 'Alternate'. We can search for full words only, but I think it is valuable to allow a partial word search

- Map page becomes non-responsive; perhaps too many clicks on controls
leads to a extensive latency.top
- Current knb.ecoinformatics.org site returns 8064 data packages for full
"lter" search or 7209 from title/abstract/...; new site returns only 214.

We have many LTER packages to index in Solr

Metadata Presentation
- Empty boxes better to state "no-content" or "content not available"; the
empty box by it self leaves one to wonder if content does exist, but
did not display for technical reasons.
There is a ticket in Metacat to alter the xls file for non-existent data attributes

- Download button at top of page only downloads EML metadata (and system metadata) without the
data entity(s); I made the assumption that the complete data package
would be zipped and downloaded; inflated zip file has directory called
"data", which I would have assumed to hold the data entity.
Some packages only contain metadata. Hopefully this will be more clear when I add a list of all downloadable files to the top of the Metadata view, similar to ONEMercury

#2 Updated by Lauren Walker almost 8 years ago

  • translation missing: en.field_remaining_hours set to 0.0
  • Status changed from New to Resolved

Also available in: Atom PDF