Project

General

Profile

Bug #639

Problem adding data to a package

Added by Dan Higgins about 17 years ago. Updated about 17 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
10/17/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
639

Description

If a package does not contain any data, and the add data menu item (Data menu)
is selected, there is a problem if one does NOT select an existing data set to
add. In this case, a 1 cell table appears. One can add rows and columns, but
after adding columns, there are problems in typing data into the cells. Also,
the 'Update' buttons fro saving any entries/changes does not work.

History

#1 Updated by Dan Higgins about 17 years ago

The problem with editing after a column has been added has been fixed by
ensuring that the proper delimiter string has been passed to the table cell
editor. There are still problems with saving the revised table.

#2 Updated by Dan Higgins about 17 years ago

Problems of adding data to a package fixed by making the "Create New
Datatable..." menu item 'smarter'. If there is no data in the current entity,
clicking this item will ask for a data file. Or, if one edits empty table
displayed when no data is in the package and then hits the 'Update' button, the
displayed table is saved as data. While if there is data in the current entity,
a new entity can be created by selecting the "Create New Datatable..." meu item.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 639

Also available in: Atom PDF