Project

General

Profile

Bug #6531

Make sure that the MN node description wouldn't be overwritten by the default value during a Metacat upgrading

Added by Jing Tao over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
04/24/2014
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

When a Metacat was configured as a DataONE member node, the node description and et al would be stored in the metacat.properties file.

When a new Metacat release comes out, the administrator will do a configuration again. When he/she configures the dataone page, the MN node description (maybe more properties) will be overwritten by the default values when he/she click bypass button.

History

#1 Updated by Jing Tao over 5 years ago

  • Assignee set to Jing Tao
  • Status changed from New to Resolved

I can't reproduce the bug any more. I also looked the code and the node description shouldn't be overwritten by the default value if the backup file has the information.

But we found that metacat need to backup the cn url. So we added this new feature that the cn url will be shown on the dataone configuration page and the value will be stored in the backup file.

Also available in: Atom PDF