Project

General

Profile

Actions

Bug #6645

closed

Download contents table does not render in MetadataIndex view unless it is a fresh page load

Added by Lauren Walker about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
Actions #1

Updated by Lauren Walker about 8 years ago

  • Status changed from New to Resolved
  • Assignee set to Lauren Walker

This bug was being caused by a race condition where the PackageTableView queries Solr for the package contents but the MetadataIndexView tries to insert the element before the results are retrieved. I added a trigger event to the PackageTableView so other views know when the table is done rendering.

Actions

Also available in: Atom PDF