Project

General

Profile

Actions

Bug #6943

closed

Group profile not rendering

Added by Lauren Walker almost 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
Start date:
01/19/2016
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

Jessica Couture brought an issue to my attention - she created a group on search.dataone.org and then when she goes to view her group profile, the page is balnk and nothing renders

Actions #1

Updated by Lauren Walker almost 7 years ago

There is a 500 Internal Server Error when trying to access getSubjectInfo() here: https://cn.dataone.org/cn/v2/accounts/CN=NCEAS-interns,DC=dataone,DC=org

I created a d1_identity ticket in DataONE Infrastructure redmine.

MetacatUI needs to be able to:
- Display a message when there is a server error for this particular request
- But first try to query for the group via /accounts/?query=... as a backup

Actions #2

Updated by Lauren Walker almost 7 years ago

  • Status changed from New to Resolved

The 500 server error was being caused by a blank member in the group. WIll create new ticket to check for blank values in form fields.

The UI will now use the accounts query service (/accounts/?query=...) as a backup source for group and person info when the usual getSubjectInfo() is unavailable.

If there is ultimately an error, the user model will be set to blank values so at least something is rendered

Actions

Also available in: Atom PDF