Project

General

Profile

Actions

Bug #7027

closed

Rerouting issues with #signin, #data, and #logout

Added by Lauren Walker over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
05/16/2016
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

There is a certain navigation pattern that causes routing errors - it seems to be whenever a user starts at the #data view, logs in, the app redirects to #signout then #data, causing log in to fail.

Actions #1

Updated by Lauren Walker over 6 years ago

  • Status changed from New to Resolved

This was caused by the DataCatalogView listening to the user model login status even after the view is closed. Now the DataCatalogView will stopListening() on close. The router now needs to call onClose() before logging the user out.

Actions

Also available in: Atom PDF