Project

General

Profile

Actions

Bug #7055

closed

Duplicate attribute code rows after "save for later"

Added by ben leinfelder over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
07/11/2016
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

The situation occurs when I have a data set with columns that are text and have code definitions associated with the text. When I'm not finished with the table but need to log out for some reason, I click save for later. When I reopen the data package and navigate to the data table of interest (that was partially complete), the text columns with coded definitions have been repopulated with the codes from the table. My previously entered code definitions are still there, but the codes themselves have now been duplicated and I have to manually remove them for any previous column of this type of data.

Actions #1

Updated by Jing Tao over 6 years ago

  • Status changed from New to In Progress

Those code definition were from the initial data when an attribute page was generated.
I added a switch to generate the attribute page with/without the initial data. When we uploaded an incompleted page, morpho will not load the initial data. This issue is gone.
Ben, would you please test it again? Thanks!

Actions #2

Updated by ben leinfelder over 6 years ago

It looks like you committed to an older branch (1.10) when we are on 1.11.x here: https://code.ecoinformatics.org/code/morpho/branches/MORPHO_1_11_0/

I was trying it out and finally realized why nothing had changed! :)

Actions #3

Updated by Jing Tao over 6 years ago

I committed to MORPHO_1_11_0_BRANCH.

Actions #4

Updated by Jing Tao over 6 years ago

  • Status changed from In Progress to Resolved
  • Assignee changed from ben leinfelder to Jing Tao

The problem is the page loaded both the initial default information and saved the information. The code was modified and the initial information will not uploaded. So only the saved information will loaded.
The problem was fixed on the 1-10 branch, 1-11 branch and trunk.

Actions

Also available in: Atom PDF