Project

General

Profile

Bug #836

database redesign for Intellectual Property Table for permissions for embargoed data

Added by Michael Lee almost 20 years ago. Updated over 17 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
misc
Target version:
Start date:
11/13/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
836

Description

"---"


Related issues

Has duplicate VegBank - Bug #824: Make website deal with user tables in vegbank, not frameworkResolved11/13/2002

History

#1 Updated by Michael Lee over 19 years ago

requires change in data model.

#2 Updated by Michael Lee over 19 years ago

From the minutes of the Sept 12 Meeting in SBA, where this idea came from:
--------------------------------------------------------------------------
2-4-1 Intellectual Property and Confidentiality.
Brad Boyle and Jerry Cooper both pointed out that much plot data needs to remain
protected for some years if authors are to agree to post their data. There
followed a discussion of how to resolve this issue.

• The current data model contains the fields “confidentiality_status” and
“confidentiality_reason” within Plot as a mechanisms for handling T&E species
and private land issues.
• We need a new permissions layer. Ideally, this would be like UNIX permissions
with groups and individuals.
• The intent is to allow contributors of data to screen potential users for some
fixed period of time so as to protect their rights and opportunities to publish
based on the data. However, the same mechanism could be used for other reasons
such as rare species or landowner issues.
• The simple version is table of Permissions to see embargoed plots including
fields for plot number, party, & permission. Confidentiality status could be
maintained within Plot, but perhaps a separate table is need in the event that
more than one embargo applies to a particular plot.
• There could be a switch in embargo to allow both observation and plot, but we
have no choosen to separate the observations.

Embargo
Embargo_ID = PK
Plot_ID = FK to Plot
Embargo_reason (need new list)
Author stipulation,
Rare species,
Landownership, Bad data
Embargo_start = Date
Embargo_stop = Date
Embargo_owner = FK to Party
Default_Status = Same list as in Permission_Status below
Permission
Permission_ID = PK
Embargo_ID = FK to Embargo
Party_ID = FK to Party
Permission_Status (use Confidentiality_Status list)
Public [Default if no embargo]
1 km radius location resolution
10 km radius [Default if landowner or rare species]
100 km radius
Location embargo
Public embargo on data [Default if reason = author]
Full embargo on data
Permission_Notes

• Business rules. The embargo owner should be able to lift the embargo for a
party or parties via a web form, as should the management team. Submitted plots
should be embargoable for up to x (5?) years, and the embargo should be renewed
twice. When a plot search reveals one or more embargoed plots, the searcher see
only accession # + email of owner

#3 Updated by Michael Lee almost 19 years ago

changes to the model will be posted to bug 824, including changes for
intellectual property

  • This bug has been marked as a duplicate of 824 ***

#4 Updated by Michael Lee over 17 years ago

changed from components that are to be deleted to "misc" so that bugs don't get
deleted with component. Sorry for all the email.

#5 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 836

Also available in: Atom PDF