Project

General

Profile

Actions

Bug #824

closed

Make website deal with user tables in vegbank, not framework

Added by Michael Lee over 21 years ago. Updated about 19 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
misc
Target version:
Start date:
11/13/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
824

Description

Ok for now. Need autofill in the certification form.


Files

moveFrameworkIntoVegBank.jpg (306 KB) moveFrameworkIntoVegBank.jpg Michael Lee, 11/11/2003 12:15 PM
moveFrameworkDD.html (14.1 KB) moveFrameworkDD.html Michael Lee, 11/11/2003 12:59 PM

Related issues

Is duplicate of VegBank - Bug #825: [1033] Management accounts??ClosedJohn Harris11/13/2002

Actions
Is duplicate of VegBank - Bug #836: database redesign for Intellectual Property Table for permissions for embargoed dataResolvedMichael Lee11/13/2002

Actions
Blocks VegBank - Bug #1219: VegBank 1.0.2 model - implementedResolvedP. Anderson11/21/2003

Actions
Actions #1

Updated by John Harris about 21 years ago

This was done fall 2002.

Actions #2

Updated by John Harris about 21 years ago

  • Bug 825 has been marked as a duplicate of this bug. ***
Actions #3

Updated by Michael Lee about 21 years ago

Need to make sure that certification documents are emailed to the appropriate
parties when someone requests certification. This list of parties probably
should be an XML doc somewhere so that we could change easily who will get the
emails.

additionally, all fields that are public in the certification form need to be
editable from the "edit profile" page :
framework/servlet/usermanagement?action=changeusersettings

Actions #4

Updated by Michael Lee over 20 years ago

profile database (framework) does not need revision for the Nov1 milestone.
Certification just needs to work. AFter ceritifcation fucntionality works, put
this bug in the 2.0 bucket.

Actions #5

Updated by P. Anderson over 20 years ago

If a user is not logged in, fills out entire form, submits, message says, "log
in" and the form data is lost. Bad news for user.

Also, "What do the levels mean?" link is broken.

Also, since only logged in users can apply for cert, we don't need the email
address to be entered, or at least we can auto populate it.

Actions #6

Updated by Michael Lee over 20 years ago

Mark, your comments above I agree with. The "what do these levels mean" link is
perhaps being screwed up my renegade javascripts elsewhere in the page, ie
footer and header. This wasn't a good idea on my part and I will be removing
them. We can find another way of linking someone to context sensitive help.

Actions #7

Updated by Michael Lee over 20 years ago

  • Bug 836 has been marked as a duplicate of this bug. ***
Actions #8

Updated by Michael Lee over 20 years ago

Mark, I'll take this bug for now, with focus on model change implications.
Sounds like the certification email is working better now- just need to get the
from: address sorted out.

Actions #9

Updated by Michael Lee over 20 years ago

more info, akin to data-dictionary on its way

Actions #11

Updated by Gabriel Farrell over 20 years ago

I see no problems with the ERD id=89 particularily in relation to user,
certification, userPermissions and embargo, userDataset and datasetObs tables.

Supporting the userQuery, recordOwnership, partyMember and userNotify are over
my horizon for now but the model looks good.

I am concerned about the SQL queries stored in the userNotity and userQuery as
there may be a more abstract way to do this that would be more robust to model
and system changes, what that way might be is unclear to me so its a moot point
for now.

Also we currently have no way to persist user preferences we may want to add
another table(s) later to support this. This can be ignored for now in the
interest of finalizing this good work and getting it in place.

Actions #12

Updated by Michael Lee over 20 years ago

Once again changing the nature and summary of this bug. Here is the task of
making the website work with the correct, new tables inside vegbank, not in
framework. Certification, authentication, log-in, etc. all need to now read
through the new tables, which are presumably populated and happy in vegbank.

Actions #13

Updated by P. Anderson almost 20 years ago

New user system works great now!

Actions #14

Updated by Michael Lee about 19 years ago

changed from components that are to be deleted to "misc" so that bugs don't get
deleted with component. Sorry for all the email.

Actions #15

Updated by Redmine Admin almost 11 years ago

Original Bugzilla ID was 824

Actions

Also available in: Atom PDF