Project

General

Profile

Actions

Bug #841

closed

Limit number of plots uploaded based on certification:test and eval

Added by Michael Lee over 21 years ago. Updated over 17 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
misc
Target version:
Start date:
11/13/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
841

Description

ML tests; TEST & BUS RULES


Related issues

Blocks VegBank - Bug #907: Business Rules:Geographic scopeResolvedMichael Lee11/13/2002

Actions
Blocks VegBank - Bug #919: Advanced IP system, user-specific filtering of dataNewMichael Lee11/27/2002

Actions
Actions #1

Updated by Michael Lee almost 21 years ago

see bug 907 for rules on where and who and how many may be uploaded to VegBank

Actions #2

Updated by Michael Lee over 20 years ago

we should create and store 2 userPreferences that they cannot control, or at
least can't override: (maybe add a field: preferenceType. values: internal,
user-set)

1) userPlotQuota : ### (plots max may be uploaded)
2) currentPlotsUploaded : ### (plots so far uploaded).

If a user attempts to load more than the quota, then the plots get rejected and
a note gets sent to them telling them why. Some rules need to be devised for
letting some users submit more plots than the normal quota. In this case,
preference #1 gets upped to a higher #.

Actions #3

Updated by Michael Lee over 19 years ago

number of plots loaded per certified user covered in bug 907

  • This bug has been marked as a duplicate of 907 ***
Actions #4

Updated by Michael Lee about 19 years ago

changed from components that are to be deleted to "misc" so that bugs don't get
deleted with component. Sorry for all the email.

Actions #5

Updated by Redmine Admin almost 11 years ago

Original Bugzilla ID was 841

Actions

Also available in: Atom PDF