Project

General

Profile

Bug #960

parser not correctly parsing <describes> tag in additionalMetadata

Added by Chad Berkley about 17 years ago. Updated almost 16 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
eml-parser
Target version:
Start date:
01/23/2003
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
960

Description

Dan Higgins pointed out to me that the example eml document in lib/sample has a
describes tag that points to a dataset tag in the document. the ids appear to
be valid but the parser says that the "describes tag must point to a valid element".

History

#1 Updated by Chad Berkley about 17 years ago

Dan updates this with the following:

I told you yesterday about a problem I had with the eml2 file
"eml-datasetWithCitation.xml" in the test directory. When it is placed into the
references parser, there was an error message about not being able to find the
reference in the 'describes' tag. When I remove all white space between the
beginning and ending <describes> tags, that problem goes away. You probably need
a 'trim()' in the code!

#2 Updated by Saurabh Garg almost 16 years ago

I checked both files mentioned in the bug.
lib/sample/eml-sample.xml
and test/eml-datasetWithCitation.xml

I was able to parse both of them without error. So maybe this bug is already
fixed. If I dont hear from anyone, then I will close it as WORKSFORME

#3 Updated by Saurabh Garg almost 16 years ago

Closing as not able to locate the problem.

#4 Updated by Redmine Admin about 7 years ago

Original Bugzilla ID was 960

Also available in: Atom PDF