Project

General

Profile

Actions

Bug #967

closed

Access control for eml2 documents

Added by Jing Tao about 20 years ago. Updated about 20 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
metacat
Target version:
Start date:
01/23/2003
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
967

Description

Access control for eml2 documents is pretty complicated.

In access control submodule, the access rules control the documents access,
this can be handled as same as eml beta6. But in additional meta data part,
user can specify another access control for a subtree of the document. This
control is not base on docid and is base on node id. So we maybe need to
change the table structure of xml_access table: adding a new field named
nodeid which is foreign key of xml_nodes table.

When we access control, it should be base on sql rather than java code.


Related issues

Has duplicate Metacat - Bug #968: Access control for eml2 documentsResolvedSaurabh Garg01/23/2003

Actions
Actions #1

Updated by Jing Tao about 20 years ago

It is duplicated bug.

  • This bug has been marked as a duplicate of 968 ***
Actions #2

Updated by Redmine Admin almost 10 years ago

Original Bugzilla ID was 967

Actions

Also available in: Atom PDF