Project

General

Profile

Bug #1109

Open button/menu fails immediately after package update

Added by Dan Higgins over 19 years ago. Updated over 18 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
06/25/2003
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1109

Description

If one tries to 'Open' packages immediately after updating a package locally
(i.e. by saving a new version of a metadata module), no window appears with a
list of packages owned by the user. The problem is a null pointer exception
generated on line 420 of the LocalQuery class. If one restarts Morpho, then the
problem disappears.

I think the problem is due to the fact that the newly created package version is
not in the datapackage cache. Need to make sure it gets cached before 'Open' is
called?

History

#1 Updated by Matt Jones over 18 years ago

If this is still a bug it needs to be resolved before 1.5 ships. Dan, please
clarify and either fix or close the bug. Thanks.

#2 Updated by Dan Higgins over 18 years ago

This bug has been fixed as the result of fixing some other errors. Newly saved
packages appear on Open list.

#3 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 1109

Also available in: Atom PDF