Project

General

Profile

Bug #1331

interface enhancements

Added by Chad Berkley over 15 years ago. Updated over 15 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
interface
Target version:
Start date:
02/09/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1331

Description

below is a list of GUI enhancements that were noted at the SEV meeting. Each
needs to be addressed before the interface is really usable. Some of these bugs
might be Mac specific but most of them are not.

--move actor config to one dialog
--make actor lib searchable
--add metadata to actors for different categorization
--make the actor lib re order itself when you choose a different director...it
should only show actors that work with that director
--allow output to be viewed on the vergil canvas
--add user documention to each actor
--make it easier to expose parameters to the run window
--allow actors to have aliases
--remove functionality that domains scientists would not use (EE stuff)
--change paste behavior to force pasted elements to be in the current clipping
view instead of the middle of the canvas
--allow all ports to display port name or have arcs display the name of the
values passed
--when you add a port, don't randomly select the cardinal direction...inputs
should be west, outputs east BY DEFAULT
--make dialogs resize based on screen resolution
--the zoom buttons are totally unintuitive. they need new icons
--allow ampersands in annotations


Related issues

Has duplicate Kepler - Bug #1330: interface enhancementsResolved02/09/2004

History

#1 Updated by Chad Berkley over 15 years ago

bastard bugzilla created 2 bugs for this

  • This bug has been marked as a duplicate of 1330 ***

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 1331

Also available in: Atom PDF