Project

General

Profile

Bug #1330

interface enhancements

Added by Chad Berkley about 15 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
interface
Target version:
Start date:
02/09/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1330

Description

below is a list of GUI enhancements that were noted at the SEV meeting. Each
needs to be addressed before the interface is really usable. Some of these bugs
might be Mac specific but most of them are not.

--move actor config to one dialog
--make actor lib searchable
--add metadata to actors for different categorization
--make the actor lib re order itself when you choose a different director...it
should only show actors that work with that director
--allow output to be viewed on the vergil canvas
--add user documention to each actor
--make it easier to expose parameters to the run window
--allow actors to have aliases
--remove functionality that domains scientists would not use (EE stuff)
--change paste behavior to force pasted elements to be in the current clipping
view instead of the middle of the canvas
--allow all ports to display port name or have arcs display the name of the
values passed
--when you add a port, don't randomly select the cardinal direction...inputs
should be west, outputs east BY DEFAULT
--make dialogs resize based on screen resolution
--the zoom buttons are totally unintuitive. they need new icons
--allow ampersands in annotations


Related issues

Is duplicate of Kepler - Bug #1331: interface enhancementsResolved2004-02-09

History

#1 Updated by Chad Berkley about 15 years ago

  • Bug 1331 has been marked as a duplicate of this bug. ***

#2 Updated by Chad Berkley about 15 years ago

I am currently working on getting the actor configurations moved into one dialog
box. I have sent off an email to ptolemy-hackers asking what the best way to
override the default configuration dialog is.

My idea is to use the same dialog (modified) that we use for the actor prototype
tool to configure the actors. I would add another part to the dialog where the
user could edit parameters. This way the ports, parameters and name of the
actor could all be configured from the same place. I am currently reworking the
actor prototyping dialog code so that it is more flexible and can be extended.

#3 Updated by Chad Berkley over 14 years ago

the following items have been fixed in one way or another. The rest I will
re-evaluate and move to individual bugs.

--make actor lib searchable
--add metadata to actors for different categorization
--allow output to be viewed on the vergil canvas
--make it easier to expose parameters to the run window
--remove functionality that domains scientists would not use (EE stuff)
--allow all ports to display port name or have arcs display the name of the
values passed
--the zoom buttons are totally unintuitive. they need new icons

#4 Updated by Christopher Brooks over 14 years ago

Chad wrote:

--the zoom buttons are totally unintuitive. they need new icons

I might be off track, but are we talking about the Vergil zoom icons?
The ones we have are magnifiying glass based, they can be found at
http://ptolemy.eecs.berkeley.edu/ptolemyII/ptII4.0/ptII4.0.1/ptolemy/vergil/basic/img/

Are you seeing these? One thing I've noticed is that if the jar files
or classpath does not include the gifs in ptolemy/vergil/basic/img, then
one gets ugly icons.

I just wanted to be sure you were seeing the standard Vergil zoom icons.

_Christopher

#5 Updated by Redmine Admin almost 6 years ago

Original Bugzilla ID was 1330

Also available in: Atom PDF