Project

General

Profile

Bug #1391

massive stack dump when editing data

Added by Chad Berkley over 18 years ago. Updated over 18 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
03/24/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1391

Description

I created a new data package, then at the end i chose the option to enter the
data manually. i got through adding attributes then I entered the first row of
data. when i hit enter after the first row, nothing happened but a 1000 line
stack dump rolled down the terminal. Here's a sampling:

java.lang.ArrayIndexOutOfBoundsException
at javax.swing.text.BoxView.getOffset(BoxView.java:1022)
at javax.swing.text.BoxView.childAllocation(BoxView.java:669)
at javax.swing.text.CompositeView.getChildAllocation(CompositeView.java:
215)
at javax.swing.text.BoxView.getChildAllocation(BoxView.java:427)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.calculateViewPositio
n(BasicTextUI.java:1780)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.layoutContainer(Basi
cTextUI.java:1756)
at java.awt.Container.layout(Container.java:980)
at java.awt.Container.doLayout(Container.java:970)
at java.awt.Container.validateTree(Container.java:1048)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validate(Container.java:1023)
at javax.swing.JViewport.validateView(JViewport.java:479)
at javax.swing.JViewport.scrollRectToVisible(JViewport.java:353)
at javax.swing.JComponent.scrollRectToVisible(JComponent.java:2620)
at javax.swing.text.DefaultCaret.adjustVisibility(DefaultCaret.java:193)

at javax.swing.text.DefaultCaret.repaintNewCaret(DefaultCaret.java:1045)
at javax.swing.text.DefaultCaret$1.run(DefaultCaret.java:1019)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:178)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:443)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchTh
read.java:191)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThre
ad.java:144)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:130)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:98)
java.lang.ArrayIndexOutOfBoundsException
at javax.swing.text.BoxView.getOffset(BoxView.java:1022)
at javax.swing.text.BoxView.childAllocation(BoxView.java:669)
at javax.swing.text.CompositeView.getChildAllocation(CompositeView.java:
215)
at javax.swing.text.BoxView.getChildAllocation(BoxView.java:427)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.calculateViewPositio
n(BasicTextUI.java:1780)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.layoutContainer(Basi
cTextUI.java:1756)
at java.awt.Container.layout(Container.java:980)
at java.awt.Container.doLayout(Container.java:970)
at java.awt.Container.validateTree(Container.java:1048)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validate(Container.java:1023)
at javax.swing.JViewport.validateView(JViewport.java:479)
at javax.swing.JViewport.scrollRectToVisible(JViewport.java:353)
at javax.swing.JComponent.scrollRectToVisible(JComponent.java:2620)
at javax.swing.text.DefaultCaret.adjustVisibility(DefaultCaret.java:193)
at javax.swing.text.DefaultCaret.repaintNewCaret(DefaultCaret.java:1045)
at javax.swing.text.DefaultCaret$1.run(DefaultCaret.java:1019)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:178)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:443)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchTh
read.java:191)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThre
ad.java:144)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:130)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:98)
java.lang.ArrayIndexOutOfBoundsException
at javax.swing.text.BoxView.getOffset(BoxView.java:1022)
at javax.swing.text.BoxView.childAllocation(BoxView.java:669)
at javax.swing.text.CompositeView.getChildAllocation(CompositeView.java:
215)
at javax.swing.text.BoxView.getChildAllocation(BoxView.java:427)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.calculateViewPositio
n(BasicTextUI.java:1780)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.layoutContainer(Basi
cTextUI.java:1756)
at java.awt.Container.layout(Container.java:980)
at java.awt.Container.doLayout(Container.java:970)
at java.awt.Container.validateTree(Container.java:1048)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validate(Container.java:1023)
at javax.swing.JViewport.validateView(JViewport.java:479)
at javax.swing.JViewport.scrollRectToVisible(JViewport.java:353)
at javax.swing.JComponent.scrollRectToVisible(JComponent.java:2620)
at javax.swing.text.DefaultCaret.adjustVisibility(DefaultCaret.java:193)
at javax.swing.text.DefaultCaret.repaintNewCaret(DefaultCaret.java:1045)
at javax.swing.text.DefaultCaret$1.run(DefaultCaret.java:1019)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:178)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:443)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchTh
read.java:191)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThre
ad.java:144)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:130)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:98)
java.lang.ArrayIndexOutOfBoundsException
at javax.swing.text.BoxView.getOffset(BoxView.java:1022)
at javax.swing.text.BoxView.childAllocation(BoxView.java:669)
at javax.swing.text.CompositeView.getChildAllocation(CompositeView.java:
215)
at javax.swing.text.BoxView.getChildAllocation(BoxView.java:427)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.calculateViewPositio
n(BasicTextUI.java:1780)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.layoutContainer(Basi
cTextUI.java:1756)
at java.awt.Container.layout(Container.java:980)
at java.awt.Container.doLayout(Container.java:970)
at java.awt.Container.validateTree(Container.java:1048)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validate(Container.java:1023)
at javax.swing.JViewport.validateView(JViewport.java:479)
at javax.swing.JViewport.scrollRectToVisible(JViewport.java:353)
at javax.swing.JComponent.scrollRectToVisible(JComponent.java:2620)
at javax.swing.text.DefaultCaret.adjustVisibility(DefaultCaret.java:193)
at javax.swing.text.DefaultCaret.repaintNewCaret(DefaultCaret.java:1045)
at javax.swing.text.DefaultCaret$1.run(DefaultCaret.java:1019)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:178)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:443)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchTh
read.java:191)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThre
ad.java:144)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:130)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:98)
java.lang.ArrayIndexOutOfBoundsException
at javax.swing.text.BoxView.getOffset(BoxView.java:1022)
at javax.swing.text.BoxView.childAllocation(BoxView.java:669)
at javax.swing.text.CompositeView.getChildAllocation(CompositeView.java:
215)
at javax.swing.text.BoxView.getChildAllocation(BoxView.java:427)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.calculateViewPositio
n(BasicTextUI.java:1780)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.layoutContainer(Basi
cTextUI.java:1756)
at java.awt.Container.layout(Container.java:980)
at java.awt.Container.doLayout(Container.java:970)
at java.awt.Container.validateTree(Container.java:1048)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validate(Container.java:1023)
at javax.swing.JViewport.validateView(JViewport.java:479)
at javax.swing.JViewport.scrollRectToVisible(JViewport.java:353)
at javax.swing.JComponent.scrollRectToVisible(JComponent.java:2620)
at javax.swing.text.DefaultCaret.adjustVisibility(DefaultCaret.java:193)
at javax.swing.text.DefaultCaret.repaintNewCaret(DefaultCaret.java:1045)
at javax.swing.text.DefaultCaret$1.run(DefaultCaret.java:1019)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:178)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:443)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchTh
read.java:191)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThre
ad.java:144)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:130)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:98)
java.lang.ArrayIndexOutOfBoundsException
at javax.swing.text.BoxView.getOffset(BoxView.java:1022)
at javax.swing.text.BoxView.childAllocation(BoxView.java:669)
at javax.swing.text.CompositeView.getChildAllocation(CompositeView.java:
215)
at javax.swing.text.BoxView.getChildAllocation(BoxView.java:427)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.calculateViewPositio
n(BasicTextUI.java:1780)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.layoutContainer(Basi
cTextUI.java:1756)
at java.awt.Container.layout(Container.java:980)
at java.awt.Container.doLayout(Container.java:970)
at java.awt.Container.validateTree(Container.java:1048)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validate(Container.java:1023)
at javax.swing.JViewport.validateView(JViewport.java:479)
at javax.swing.JViewport.scrollRectToVisible(JViewport.java:353)
at javax.swing.JComponent.scrollRectToVisible(JComponent.java:2620)
at javax.swing.text.DefaultCaret.adjustVisibility(DefaultCaret.java:193)
at javax.swing.text.DefaultCaret.repaintNewCaret(DefaultCaret.java:1045)
at javax.swing.text.DefaultCaret$1.run(DefaultCaret.java:1019)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:178)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:443)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchTh
read.java:191)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThre
ad.java:144)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:130)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:98)
java.lang.ArrayIndexOutOfBoundsException
at javax.swing.text.BoxView.getOffset(BoxView.java:1022)
at javax.swing.text.BoxView.childAllocation(BoxView.java:669)
at javax.swing.text.CompositeView.getChildAllocation(CompositeView.java:
215)
at javax.swing.text.BoxView.getChildAllocation(BoxView.java:427)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.calculateViewPositio
n(BasicTextUI.java:1780)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.layoutContainer(Basi
cTextUI.java:1756)
at java.awt.Container.layout(Container.java:980)
at java.awt.Container.doLayout(Container.java:970)
at java.awt.Container.validateTree(Container.java:1048)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validate(Container.java:1023)
at javax.swing.RepaintManager.validateInvalidComponents(RepaintManager.j
ava:347)
at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(System
EventQueueUtilities.java:116)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:178)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:443)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchTh
read.java:191)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThre
ad.java:144)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:130)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:98)
java.lang.ArrayIndexOutOfBoundsException
at javax.swing.text.BoxView.getOffset(BoxView.java:1022)
at javax.swing.text.BoxView.childAllocation(BoxView.java:669)
at javax.swing.text.CompositeView.getChildAllocation(CompositeView.java:
215)
at javax.swing.text.BoxView.getChildAllocation(BoxView.java:427)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.calculateViewPositio
n(BasicTextUI.java:1780)
at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.layoutContainer(Basi
cTextUI.java:1756)
at java.awt.Container.layout(Container.java:980)
at java.awt.Container.doLayout(Container.java:970)
at java.awt.Container.validateTree(Container.java:1048)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validateTree(Container.java:1055)
at java.awt.Container.validate(Container.java:1023)
at javax.swing.RepaintManager.validateInvalidComponents(RepaintManager.j
ava:347)
at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(System
EventQueueUtilities.java:116)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:178)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:443)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchTh
read.java:191)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThre
ad.java:144)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:130)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:98)

History

#1 Updated by Dan Higgins over 18 years ago

At least in my initial attempt, I cannot reproduce this problem !

#2 Updated by Chad Berkley over 18 years ago

The stack dump is now gone. Dan thinks it was fixed with another bug
yesterday.

#3 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 1391

Also available in: Atom PDF