Project

General

Profile

Bug #1445

morpho editor causes validation problem

Added by Chad Berkley over 18 years ago. Updated over 18 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
04/05/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1445

Description

whenever you open a package with the editor (via the Documentation/Add,Edit
Documentation menu item), whether you change the file or not, when you click ok,
you get this error:

Validation problem: Exception:cvc-complex-type.2.4.a: Invalid content starting
with element 'fieldWidth'. The content must match
'(("":fieldWidth),("":lineNumber){0-1},("":fieldStartColumn){0-1})'.

History

#1 Updated by Dan Higgins over 18 years ago

I have been unable to reproduce this error (and especially this error message).

I suspect this is a problem with the package data (attempt to handle
textFixed/fieldWidth tag in textFormat

#2 Updated by Dan Higgins over 18 years ago

This problem is created by repeated, sequential <fieldWidth> elements. Actually,
it is the parent of <fieldWidth> that needs to be repeated. The problem is
caused by the document created by the Wizard, not the editor. (The first
validation is done when the editor saves; this is why it appears to be an editor
problem.)

#3 Updated by Perumal Sambasivam over 18 years ago

fixed the code so that the "textFixed" element and the "textDelimited" element
are repeated instead of the "fieldWidth" element, when there is more than one
field.

#4 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 1445

Also available in: Atom PDF