Project

General

Profile

Bug #1486

editing referenced party on project screen loses role

Added by Matt Jones over 18 years ago. Updated over 18 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
04/14/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1486

Description

Whn adding a research project in the DPW, a party was chosen from the references
list and a role selected. When returning to that screen and editing the
original party, the role is lost, and the package is invalid.

Steps to reproduce:
1) Open morpho, start DPW, enter title and "User One" as creator and one contact
2) Proceed to project screen, fill in project title, add reference to "User One"
3) Select role for "User One" to be "Principal Investigator" and hit "OK"
4) Click "Edit" to edit the party you just entered
5) Check the "Do you want to edit the above information?" box and make a change
and hit "OK"
6) Note that the role is no longer present in the summary list
7) proceed through wizard and save document, which is now invalid due to missing
role

History

#1 Updated by Dan Higgins over 18 years ago

Bug fixed;

Problem was the same as previously encountered with lossing the role in the
AssociatedParty dialog. Private method in Project class
(updateOriginalRefPartyPage) changed to avoid overwriting the new party

Same error was in the Citation class. Code fixed there also.

#2 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 1486

Also available in: Atom PDF