Project

General

Profile

Bug #1490

problems importing space delimited data file

Added by Matt Jones almost 17 years ago. Updated almost 17 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
04/15/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1490

Description

Attempting to import a space delimited data file with multiple spaces between
each column results in 1) a view that misses some of the data, and 2) an invalid
EML document that won't save to metacat due to validity problems. I am not
sure this has to do with the delimiter, but other csv file imports have worked
fine for me, so its a working theory. The problem is consistent on linux and
windows for the data file that I will attach, and the generated EML willbe
attached as well.

345.1 (618 Bytes) 345.1 Matt Jones, 04/15/2004 11:58 AM
342.4 (11.5 KB) 342.4 Matt Jones, 04/15/2004 11:59 AM

History

#3 Updated by Matt Jones almost 17 years ago

The validation problem seems to be that it is leaving out the 'unit' field for
the two ratio attributes, even though I selected "Amount|dimensionless" for each
of them as the unit when going through the DPW. Here's the validation error:

cvc-complex-type.2.4.a: Invalid content starting with element 'precision'. The
content must match '((("":unit),("":precision)),("":numericDomain))'.

#4 Updated by Dan Higgins almost 17 years ago

The validation problem has been fixed with the unit fix (Bug 1489), but there is
still a display problem when the data file is shown in the data table for the
package. This is caused by the fact that there is still no information in the
eml metadata to indicate that there are multiple repeated delimiters that should
be treated as a single delimiter (in this case, multiple spaces).

#5 Updated by Dan Higgins almost 17 years ago

see bug #1358

#6 Updated by Dan Higgins almost 17 years ago

fixed by adding 'additionalMetadata' tag with 'describes' pointed to a physical'
id of the table and a tag (<consecutiveDelimiters>) with boolean 'true' if we
are to ignore consecutive delimiters.

The method do look for this information in in the EML200DataPackage class
(virtual in AbstractDataPackage) so we can change easily for updated emls that
have a tag elsewhere.

#7 Updated by Redmine Admin almost 8 years ago

Original Bugzilla ID was 1490

Also available in: Atom PDF