Project

General

Profile

Bug #1521

Column name labels in Morpho Data Table Display disappear

Added by Rick Reeves over 15 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
04/19/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1521

Description

Displaying a data table for an existing Morpho data package using the 'tabbed
dialog' display. The column widths are adjustable; if I slide one column to
the left (making the column to the left narrower), the (Boldface) column name
disappears, even though the column units do not completely disappear.

I originally discovered this when importing an existing table in which one of
the column units was MolesKilogramMeterSquared or some such very long string.
The long string was truncated in the table display, but the boldface column
name did not get displayed.

History

#1 Updated by Dan Higgins over 15 years ago

Multiline column headers are implemented using html label. The problem is that
Java's html renderer inserts a blink line when the column is too narrow and this
pushes the last of the three lines in the header below the bottom of the display
area. I have been unable to find a way to prevent this, short of customizing the
whole ColumnHeader class. This may be required for a fix, but cannot complete
prior to 1.5 release.
Thus move to 1.6

#2 Updated by ben leinfelder almost 7 years ago

The bold faced headers show even if the column width is made smaller than the width of the text. Assume some improvements were made in the 8 years since this was entered...

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 1521

Also available in: Atom PDF