Project

General

Profile

Bug #1628

Drools Rules - more sophisticated rules for data editor

Added by Matthew Brooke almost 15 years ago. Updated about 14 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
jalama-general
Target version:
Start date:
07/07/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1628

Description

Make rules more sophisticated in order to populate the UI labels etc in a more
user-friendly.manner.

1) Look for an attribute/attributeLabel (not a required element), and use it if
it exists, otherwise, use attributeName (required)

2) Look at the eml-constraint for each attribute, and if it's "not nnull", then
make the input widget require a value (minoccurs=1) - if it's not required, make
minoccurs=0

3) Need to look carefully at EML and decide what other info can be used -
documentation etc?


Related issues

Has duplicate Jalama - Bug #1934: XBL Datatable Widget - Implement Overridable ValidationIn Progress02/01/2005

History

#1 Updated by Matthew Brooke over 14 years ago

have done (1) - "Look for an attribute/attributeLabel (not a required element),
and use it if
it exists, otherwise, use attributeName (required)"

#2 Updated by Matthew Brooke about 14 years ago

moved remaining part of this bug to bug #1934

  • This bug has been marked as a duplicate of 1934 ***

#3 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 1628

Also available in: Atom PDF