Project

General

Profile

Bug #1710

taxonomicClassificationSystem not created correctly from GUI

Added by Chad Berkley almost 15 years ago. Updated over 14 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
09/29/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1710

Description

the GUI editor for taxonomicClassificationSystem is not providing the required
content inside taxonomicClassificationSystem. if you use this part of the
document, it will not validate upon submission to metacat.

History

#1 Updated by Saurabh Garg over 14 years ago

The problem is with the defining a citaion as report. According to EML, none of
the report tags are required. And the way DPW is designed, it cannot have maps
with empty values in it. And in eml, if title and creator tags are there but
there is no book, article or report tags, it would be invalid eml.

So these are the options to fix this:

1. Make publisher and report number as required fields in Morpho - even though
these are not required in EML

2. Remove Report option from this screen.

3. Modify the code to produce eml which has empty tags in it. THis will take
longer time as this will effect the tree editor also.

I think option #1 is the best. If anyone thinks that would be wrong, then plz
let me know. Otherwise I will fix this using option #1.

#2 Updated by Saurabh Garg over 14 years ago

Fixed using option 1.

Also fixed another bug. To reproduce that bug, in the old code - add a citation
then click on add button, give title and creator information and hit ok. An
exception is generated because citationType is not null when any new citation
is added. citationType should be null if no citation has been selected.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 1710

Also available in: Atom PDF