Project

General

Profile

Actions

Bug #180

closed

return of DTD comments with documents should be eliminated

Added by Dan Higgins about 23 years ago. Updated almost 22 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
metacat
Target version:
Start date:
01/08/2001
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
180

Description

Currently, if I submit an XML metadata document to Metacat and then retrieve
that document, the retrieved document contains
comment fields from its DTD that were NOT present in the original document. A
user should retrieve a document
from metacat that is a duplicate of the one submitted and comments in the DTD
should remain in the DTD only. Putting them into a returned
document tends to confuse the user into thinking that the retrieved document is
not the same one as submitted.

Actions #1

Updated by Jivka Bojilova about 23 years ago

DONE
When comments are reported in DBSAXHandler, processingDTD flag is used to
eliminate storing of the comments coming from the DTD file

Actions #2

Updated by Redmine Admin almost 11 years ago

Original Bugzilla ID was 180

Actions

Also available in: Atom PDF