Project

General

Profile

Bug #2067

Configure Ports command causes error with PTII CVS

Added by Dan Higgins over 14 years ago. Updated over 14 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
actors
Target version:
Start date:
04/17/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2067

Description

When using the Ptolemy CVS version as the basis for Kepler and compiling from
Ant, trying the 'Configure Ports' command for any actor causes a 'Failed to
create Dialog Tableau' error. Following the stack trace indicates 'Caused by:
java.lang.NoSuchMethodError: ptolemy.data.expr.Constants.types()Ljava/util/TreeMap;'

This error disappears if the src/exp/ptolemy/data/expr/Constants.java code is
removed from Kepler. (Some kind of problem with new PT code?)

Jing reports that the error does NOT appear when using Eclipse !

History

#1 Updated by Dan Higgins over 14 years ago

Updated the Kepler version of Constants.java to include new features that are in
the PT CVS version (which included changes that allow for types to be chosen
from a list in the Configue Ports dialog).

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2067

Also available in: Atom PDF