Project

General

Profile

Bug #2347

Need to be able to terminate workflow 'animation/feedback'

Added by Dan Higgins almost 14 years ago. Updated almost 14 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
general
Target version:
Start date:
01/29/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2347

Description

In using the new Kepler menu system, I can across a problem. In the old
menus (aka Ptolemy menu) there is a menu item named 'Animate Execution' under
the 'Debug' menu. Immediately below the 'Animate Execution' is a 'Stop
Animating' meny item.

'Animate Execution' shows when actors are executing when a workflow runs by
'hilighting' the actor for a use-set period of time (for some Directors). 'Stop
Animating' turns off the animation
In the new menus, this item has apparently been replaced by the menu item
'Run with Feedback' under the 'Tools' menu. The problem is that there is no
'Stop Feedback' menu item. So once the user starts showing which icon is firing,
there is no way to turn off the effect with the new menus! Rather that having a
separate 'Stop' menu, perhaps the menu should toggle from 'Run with Feedback' to
'Stop Feedback' and back?
Incidently. in my opinion, the original menu text of 'Animate Execution'
seems more descriptive than 'Run with Feedback'. Feedback seems like a term that
can have many meanings and is not very helpful to a new Kepler user.. 'Feedback'
could just be some text summary at the end of workflow execution.
Dan Higgins 1/29/2006

History

#1 Updated by Matthew Brooke almost 14 years ago

replaced with a JCheckBoxMenuItem to match new design. now toggles on and off.
Dan's namign comments are being discussed on Kepler-Dev

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2347

Also available in: Atom PDF