Project

General

Profile

Bug #2399

problems with GARP_SingleSpecies_BestRuleSet.xml

Added by Dan Higgins about 13 years ago. Updated about 13 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
pipelines
Target version:
Start date:
04/06/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2399

Description

The workflow "GARP_SingleSpecies_BestRuleSet.xml" (#19 in the GARP example list) will crash if the numIterations parameter is given too small of a value. Actually, the problem is the relative values of several parameters. There is another parameter called 'onissionFraction' (set to 0.1 by default). That parameter times the numIterations must be greater than 'numBestRulesets (=3 by default) or GARP tries to run with a nil ruleset (which crashes everything).

History

#1 Updated by Dan Higgins about 13 years ago

Revised the RScript so that a nil ruleset is not sent to the GARP actor. This fix added some parameter checks to the script.

#2 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 2399

Also available in: Atom PDF