Project

General

Profile

Bug #2407

Kepler process keeps running after close all windows

Added by Jing Tao about 13 years ago. Updated about 13 years ago.

Status:
Resolved
Priority:
Normal
Category:
general
Target version:
Start date:
04/07/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2407

Description

If you turn off welcome screen, then run kepler again. You will find kepler process keeps running after close all windows. We guess turning off welcome screen only makes it invisible.

History

#1 Updated by Dan Higgins about 13 years ago

HINT: in Kepler, you can get the WelcomeWindow to show up again by deleting the file .ptolemyII in your 'home' direcotry.

#2 Updated by Christopher Brooks about 13 years ago

I'll handle this one.
The problem is that we have a tableau associated with welcome window.
It will be a little while before I get to this.

#3 Updated by Christopher Brooks about 13 years ago

Fixed by updating ptii/ptolemy/actor/lib/WelcomeWindow:
show(): Call super.close() because _close() expects that the window has been
rendered via successful completion of show() and that we can query the
checkbox. There was a bug where if user started Kepler, unchecked
"Show this Window at Startup" and then restarted Kepler, Kepler would
not exit.

#4 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2407

Also available in: Atom PDF