Project

General

Profile

Bug #2421

Port Name bug in SummaryStatistics actor

Added by Dan Higgins over 13 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
actors
Target version:
Start date:
04/18/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2421

Description

Dan Higgins wrote:

Hey Chad,

If I simply drag the SummaryStatistics actor (a specialized version of the RExpression actor) onto the workspace and look at the ports, the port names have changed with each name preceeded by 'kepler:' e.g. 'xmean' becomes 'kepler:xmean'. The 'kepler:' part of the port names is NOT in the SummaryStatistics.xml for the actor in the KAR. Is it coming from the moml parser? In any case, this change in port name causes a problem with the actor, since the name should correspond to a variable name in the R script!

Dan

hmm, that's supposed to get stripped out of there. not sure why it's not. the problem is that we have properties that describe the ports and they have the same name as the port that is being described. If the moml parser tries to load that, we get a nameduplicationexception. so i tagged them with kepler: but they're supposed to get stripped when it gets instantiated. could you enter a bug for this?

thanks,
chad

History

#1 Updated by Dan Higgins over 13 years ago

I suspect that the problem occurs for all derived actors. This would mean the any actors built on RExpression would not work properly.

#2 Updated by Chad Berkley over 13 years ago

I had missed two spots where a port was created and the name was not changed. this is now fixed.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2421

Also available in: Atom PDF