Project

General

Profile

Bug #2427

EML2 Data Source problems with local metadata/data

Added by Dan Higgins over 13 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
actors
Target version:
Start date:
04/25/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2427

Description

There are several problems with using the EML DataSource actor with local EML metadata and associated data files.

First of all, the parameter where one sets the local EML file apparently requires the full path and Kepler expressions cannot by used. One thus cannot set the path with expressions, meaning that using on different machines is impossible.

Secondly, the paths in the EML that link to the local data apparently require 'file:.." urls with a complete path. This requires hand editing of the eml (Morpho output will not work) and is machine specific.

History

#1 Updated by Dan Higgins over 13 years ago

I created a workflow with an eml datasource using a local EML file. It worked. Closing Kepler and reopening works UNTIL I delete the cache. Then trying to open the workflow 'hangs' kepler with message:

java] getEndpoint - ENDPOINT attr is null.
java] Java Result: 1

#2 Updated by Jing Tao over 13 years ago

I tried the workflow which dan use local eml file. After deleting cache, I can still open it and run it without any problem. But my OS is linux and dan's is windows. I will try the windows to see if i can duplicate the problem.

#3 Updated by Dan Higgins over 13 years ago

I can open the workflow OK on Windows using last nights zip, but I CANNOT with a brand new checkout of Kepler CVS (on windows). It also works on the Mac using last nights zip file!

#4 Updated by Jing Tao over 13 years ago

I tried a brand new cvs checkout of kepler and ptolemy in windows, it work fine to me!

#5 Updated by Jing Tao over 13 years ago

It is a thread issue. So how an Entity object not be assinged value (keep null) before it was called. The fixed was checked into cvs and now is working for dan.

#6 Updated by Jing Tao over 13 years ago

Now I added code to get the EML file location from parameter. And it works for me in both windows and linux machine.

But Dan got the kepler hang there when he tried to open this workflow in windows.

#7 Updated by Jing Tao over 13 years ago

This is a muti-thread issue. I added more controls in metadata downloading. Now Dan can successfully run the workflow.

#8 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2427

Also available in: Atom PDF