Project

General

Profile

Bug #2431

Revision number of Inserted Tables are not working

Added by Callie Bowdish over 13 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
04/28/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2431

Description

When saving a Data Package up to Metacat the id number for the table does not increase the revision number. Saving a change in a dp's table results in the table id changing from 190.1 to 191.1. The table id number should change to 190.2.

To test this create a dp and import a table. Save the dp. Then make and save a change to the table column data. The new id for the table will change to a new ids number rather than a revision number.

One thing to consider is that it would be hard to find the previous version of the data table on metacat if this occurs. This happens with Morpho saveing locally and with saving to the network. (I put a bug in for Metacat too #2430)

History

#1 Updated by Jing Tao over 13 years ago

This bug was caused by dataFileId wasn't set in DataViewer class. Now it has been fixed. I tested to create single table, mutipile-tables in morpho and it worked fine to me.

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2431

Also available in: Atom PDF