Project

General

Profile

Bug #2438

Actors to be Renamed

Added by Matthew Brooke over 13 years ago. Updated almost 12 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
actors
Target version:
Start date:
05/16/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2438

Description

During icon assignment conference calls, Matt identified these actors as ones that should be re-named to be more descriptive of their actual functionality:

ptolemy.actor.lib.Accumulator
- rename from "Accumulator" to "Summation"

org.kepler.objectmanager.cache.DataCacheGetActor
- rename from "Filesystem cache get" to "Cache Get"

org.kepler.objectmanager.cache.DataCachePutActor
- rename from "Filesystem cache Put" to "Cache Put"


Related issues

Has duplicate Kepler - Bug #2828: Actor names inconsistentIn Progress04/18/2007

History

#1 Updated by Matthew Brooke over 13 years ago

also:

org.kepler.actor.moml.RBoxPlot
- rename from "RBoxPlot" to "Box Plot"

#2 Updated by Matthew Brooke over 13 years ago

also:

ptolemy.actor.lib.image.ImageToString
- This actor gets the width and height of an image as a String; it does not do any conversion - so rename from "Convert Image To String" to something more appropriate, like "Get Image Dimensions As String" or something less verbose but equally descriptive.

#3 Updated by Matthew Brooke over 13 years ago

org.geon.FileToArray
- file to array converter is not really a converter - from javadoc:
"FileToArray
This actor reads a file or URL and outputs an array of the evaluations of
all lines read. The file or URL is specified using any form acceptable
to FileParameter."

org.geon.FileToString is not really a converter - from javadoc:
- file to string converter
"FileToString
This actor reads a file or URL and outputs its content in a single string.
The file or URL is specified using any form acceptable to FileParameter."

#4 Updated by Dan Higgins almost 12 years ago

Combined with Bug #2828

  • This bug has been marked as a duplicate of 2828 ***

#5 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2438

Also available in: Atom PDF