Project

General

Profile

Bug #2567

Can't delete local dp's on Windows XP

Added by Will Tyburczy over 13 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
10/17/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2567

Description

Users are currently unable to delete local copies of data sets they've created. Select "Delete" from the "File" menu, choose "delete local copy" and hit delete, then confirm the action. YOu will get a pop-up window that says "user couldn't delete local copy. This occurs regardless of whether the user is logged in or whether the dp has a data table included. This behavior only occurs on Windows machines.

History

#1 Updated by Will Tyburczy over 13 years ago

We tested Morpho version 1.6.0 and it seems to delete files properly, so this was broken in the 1.6.1 release.

#2 Updated by Callie Bowdish over 12 years ago

I helped a user that had problems because of this feature no working. She also was unable to delete a table successfully within a data set. I think when Windows is able to delete a data package we also need to check that Morpho can delete the tables within a data package and add new ones afterwards.

#3 Updated by Callie Bowdish about 12 years ago

Jing and I had a discussion on this issue today. Shaun is going to be working on trouble shooting the online edit and delete features on the NCEAS Repository. This will help users to delete "network" knb data packages. We will still need to fix the Morpho problem for Windows users. I am currently uncomfortable with having users work with the edit delete features online because of the current problems.

#4 Updated by Jing Tao over 11 years ago

Hi, callie: I just checked out a morpho from CVS head. Then I ran morpho by typing "ant clean morpho". I created a very simple local package and i can delete it successfully. Would you please double check if the bug is still there?

Thanks!

#5 Updated by Jing Tao over 11 years ago

I just tried package with data, the morpho from cvs head can delete them too.

I also download morpho 1.6.1 into the same machine. The morpho 1.6.1 couldn't delete any package with/without data file.

So I think the bug was fixed somehow.

#6 Updated by Jing Tao over 11 years ago

Callie tested and think we can close it.

#7 Updated by Jing Tao over 10 years ago

move to 1.7

#8 Updated by Redmine Admin about 7 years ago

Original Bugzilla ID was 2567

Also available in: Atom PDF