Project

General

Profile

Bug #2716

KNB Data Catalog Map does not display points

Added by Callie Bowdish almost 13 years ago. Updated over 12 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
metacat
Target version:
Start date:
01/08/2007
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2716

Description

Metacat data bounds is not working working for the KNB Data Catalog Map. http://knb.ecoinformatics.org/index_map.jsp displays the map with no points representing the datasets. The option box Dataset Bounds text is crossed out.

Here is the errors in the server log that jing saw:
org.vfny.geoserver.wms.WmsException: java.util.NoSuchElementException: Could not locate FeatureTypeConfig 'metacat:data_bounds'
at org.vfny.geoserver.wms.requests.GetMapKvpReader.findLayer(GetMapKvpReader.java:1215)
at org.vfny.geoserver.wms.requests.GetMapKvpReader.parseLayersParam(GetMapKvpReader.java:1190)
at org.vfny.geoserver.wms.requests.GetMapKvpReader.parseLayersAndStyles(GetMapKvpReader.java:688)
at org.vfny.geoserver.wms.requests.GetMapKvpReader.parseMandatoryParameters(GetMapKvpReader.java:389)
at org.vfny.geoserver.wms.requests.GetMapKvpReader.getRequest(GetMapKvpReader.java:226)
at org.vfny.geoserver.servlets.AbstractService.doGet(AbstractService.java:318)

jing and some error about the file couldn't find:
/var/www/org.ecoinformatics.knb1/knb/data/metacat_shps/data_points.shp

History

#1 Updated by Jing Tao almost 13 years ago

After changing regenerateSpacialCache's value to true in metacat.properties, the tomcat restarted. It took about 30 minutes to regenerate the cache. The knb site now is working.

#2 Updated by Callie Bowdish almost 13 years ago

The KNB Data Catalog Map has had the Dataset Points be unavailable three different times. After each one it requires a reboot to get it to work again. Jing mentioned that the the spatial cache is kind of corrupted. Because of the way this is set up we have a blank spot on the front page where it says "View Interactive Map".

#3 Updated by Jing Tao over 12 years ago

According to my search and conversation with Matt Perry, the problem is we use shape file to store the geo information which is not recommended in a production
server.

I tried to insert and delete 400 eml docs to the test server from 4 machines simultaneously. However, i can't duplicate the problem.

In KNB machine, the problem happened once a week in avarage

#4 Updated by Matt Jones over 12 years ago

Fixed by synchronizing for multithreaded access to the shapefile.

#5 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2716

Also available in: Atom PDF