Project

General

Profile

Bug #28

need doctype backtracing/linking feature as part of doctype filter

Added by Matt Jones over 19 years ago. Updated over 17 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
metacat
Target version:
Start date:
06/20/2000
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
28

Description

When a user specifies a return type for document types, only those document
types specified are returned. There should be an option to trace the links
between query hits (on filtered doc types) and the requested document types.
For example, if a query hits an eml-variable metadata document, but the user has
only requested eml-dataset type documents be returned, the query engine should
trace the "relations" element, or its successor, to determine if there is an
eml-dataset document associated with the hit. If so, the catalog should return
it.


Related issues

Has duplicate Metacat - Bug #113: need "dataset oriented" html interface for resultsResolved09/20/2000

Blocks Metacat - Bug #31: need dataset id reference from metadataResolved06/21/2000

History

#1 Updated by Matt Jones about 19 years ago

This feature depends on us resolving the linking feature described in bug #31
that allows us to specify relationships among datasets and metadata documents.

#2 Updated by Matt Jones about 19 years ago

reassigned to berkley

#3 Updated by Chad Berkley about 19 years ago

same as bug 113

  • This bug has been marked as a duplicate of 113 ***

#4 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 28

Also available in: Atom PDF