Project

General

Profile

Bug #113

need "dataset oriented" html interface for results

Added by Matt Jones about 19 years ago. Updated over 17 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
marine
Target version:
Start date:
09/20/2000
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
113

Description

The current HTML interface displays result sets as a table, with all metadata
documents displayed. We need to modify this so that only "dataset" proxies are
displayed and the "related" metadata documents and data entities are displayed
as a collapsable hierarchical tree below each data set entry. For example:

  • Dataset title * general metadata * data entity 1 * metadata for data entity 1 * data entity 2 * metadata for data entity 2

Related issues

Is duplicate of Metacat - Bug #28: need doctype backtracing/linking feature as part of doctype filterResolved06/20/2000

History

#1 Updated by Chad Berkley about 19 years ago

This addition to the functionality will be aided by the completion of the
package spec. Packaging can be used to create this backtracking effect.

#2 Updated by Chad Berkley about 19 years ago

  • Bug 28 has been marked as a duplicate of this bug. ***

#3 Updated by Chad Berkley about 19 years ago

Created a backtracking scheme derived from relationships entered under the
package dtd. The servlet parameter returndoc is used to specify what kind of
document(s) should be displayed. When a query is performed, if the system makes
a hit on a document that is not of type returndoc then it traces the
relationship looking for a relationship between the hit document and a document
of type returndoc. If a relationship is found the related document is returned,
if not the original is returned.

#4 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 113

Also available in: Atom PDF